mirror of
https://github.com/status-im/status-react.git
synced 2025-01-11 19:44:47 +00:00
Jakub Sokołowski
7b6b620ceb
Changes: - Add `nix/DETAILS.md` for more in-depth info - Rename some of `config.status-im` variables - Drop `env` argument for Android build - Use `overlays` instead of `packageOverrides` - Move the `pkgs` overlay to `nix/overlay.nix` - Move `nix/status-go/utils.nix` to `nix/tools` - Make `shell.nix` use the `shells.default` only - Use `default.nix` as target for `nix/scripts/shell.sh` - Make `nix/scripts/shell.sh` use `--attr` instead of `target` - Drop the `target` argument in favour of using `--attr` - Drop unnecessary `src` from `nix/mobile/ios/default.nix` - Move `mkShell` and `mergeSh` under `lib` - Move `patched-go` package to `nix/pkgs` directory - Move `gomobile` package to `nix/pkgs` directory - Move `ANDROID_ABI_SPLIT` to `config.status-im.android.abi-split` - Move `ANDROID_ABI_INCLUDE to `config.status-im.android.abi-include` Signed-off-by: Jakub Sokołowski <jakub@status.im>
16 lines
570 B
Diff
16 lines
570 B
Diff
diff --git a/cmd/gomobile/bind_androidapp.go b/cmd/gomobile/bind_androidapp.go
|
|
index 3b01adc..76216fa 100644
|
|
--- a/cmd/gomobile/bind_androidapp.go
|
|
+++ b/cmd/gomobile/bind_androidapp.go
|
|
@@ -372,6 +372,10 @@ func androidAPIPath() (string, error) {
|
|
var apiVer int
|
|
for _, fi := range fis {
|
|
name := fi.Name()
|
|
+ // Resolve symlinked directories (this is how the Nix Android SDK package is built)
|
|
+ if fi2, err := os.Stat(filepath.Join(sdkDir.Name(), name)); err == nil {
|
|
+ fi = fi2
|
|
+ }
|
|
if !fi.IsDir() || !strings.HasPrefix(name, "android-") {
|
|
continue
|
|
}
|