mirror of
https://github.com/status-im/status-react.git
synced 2025-01-09 10:42:53 +00:00
2c96c38339
fixes #18831 We update the nix derivation to build android by passing `hermesEnabled` flag which checks the environment variable and if the environment variable is not set we default `hermesEnabled` to `true`. This ensures that `hermes` is disabled for debug builds and enabled for release builds. In this commit we also - rename `nix/mobile/android/release.nix` → `nix/mobile/android/build.nix` since that nix file no longer generates release only builds. - cleanup 2 other env vars and use the `gradle` project format - replace `BUILD_NUMBER` with `verisonCode` for consistency - replace `androidGradleOpts ` with `buildUrl ` - bump `status-jenkins-lib` to v1.8.7
28 lines
583 B
Nix
28 lines
583 B
Nix
{ pkgs, deps, callPackage, mkShell
|
|
, jsbundle, status-go, androidPkgs, androidShell }:
|
|
|
|
rec {
|
|
build = callPackage ./build.nix {
|
|
inherit jsbundle status-go;
|
|
};
|
|
|
|
shell = mkShell {
|
|
buildInputs = with pkgs; [
|
|
openjdk
|
|
gradle
|
|
lsof # used in start-react-native.sh
|
|
flock # used in nix/scripts/node_modules.sh
|
|
];
|
|
|
|
inputsFrom = [
|
|
(build {})
|
|
androidShell
|
|
];
|
|
|
|
shellHook = ''
|
|
# check if node modules changed and if so install them
|
|
$STATUS_MOBILE_HOME/nix/scripts/node_modules.sh ${deps.nodejs-patched}
|
|
'';
|
|
};
|
|
}
|