mirror of
https://github.com/status-im/status-mobile.git
synced 2025-02-10 15:46:35 +00:00
Changes: - Fixed `nix/status-go/desktop` builds - Dropped nimbus wrapper for `status-go` for now - Split `status-go` builds into subfolders: `mobile`, `desktop` - Fixed shells for desktop builds: `linux`,`macos`,`windows` - Added `make status-go-*` targets for building them - Moved source management to `nix/status-go/source.nix` - Moved `nix/status-go/build.nix` into `nix/status-go/mobile` - Moved `nix/desktop/cmake/qtkeychain` to `nix/pkgs/qtkeychain-src` - Moved `nix/desktop/linux/linuxdeployqt` to `nix/pkgs` - Moved `nix/desktop/linux/appimagekit` to `nix/pkgs` - Dropped `nix/tools/mkShell.nix` since it did almost nothing - Dropped `nix/desktop/cmake/snorenotify` since it's broken - Moved setup from `nix/tools/mkShell.nix` to `nix/shells.nix` - Simplified `nix/mobile/ios/status-go-shell.nix` - Simplified `nix/status-go/default.nix` - Updated the `nix/DETAILS.md` and `nix/README.md` - Moved known issues to `nix/KNOWN_ISSUES.md` - Improved output of `nix/scripts/build.sh` Signed-off-by: Jakub Sokołowski <jakub@status.im>
40 lines
2.4 KiB
Diff
40 lines
2.4 KiB
Diff
diff --git a/tools/linuxdeployqt/shared.cpp b/tools/linuxdeployqt/shared.cpp
|
|
index 4c0919a..1a136e0 100644
|
|
--- a/tools/linuxdeployqt/shared.cpp
|
|
+++ b/tools/linuxdeployqt/shared.cpp
|
|
@@ -833,20 +833,23 @@ void changeIdentification(const QString &id, const QString &binaryPath)
|
|
LogNormal() << "Checking rpath in" << binaryPath;
|
|
QString oldRpath = runPatchelf(QStringList() << "--print-rpath" << binaryPath);
|
|
LogDebug() << "oldRpath:" << oldRpath;
|
|
- if (oldRpath.startsWith("/")){
|
|
- LogDebug() << "Old rpath in" << binaryPath << "starts with /, hence adding it to LD_LIBRARY_PATH";
|
|
- // FIXME: Split along ":" characters, check each one, only append to LD_LIBRARY_PATH if not already there
|
|
- QProcessEnvironment env = QProcessEnvironment::systemEnvironment();
|
|
- QString oldPath = env.value("LD_LIBRARY_PATH");
|
|
- if (not oldPath.contains(oldRpath)){
|
|
- QString newPath = oldRpath + ":" + oldPath; // FIXME: If we use a ldd replacement, we still need to observe this path
|
|
- // FIXME: Directory layout might be different for system Qt; cannot assume lib/ to always be inside the Qt directory
|
|
- LogDebug() << "Added to LD_LIBRARY_PATH:" << newPath;
|
|
- setenv("LD_LIBRARY_PATH",newPath.toUtf8().constData(),1);
|
|
+
|
|
+ QStringList rpath = oldRpath.split(":", QString::SkipEmptyParts);
|
|
+ foreach(QString path, QStringList(rpath)) {
|
|
+ if (path.startsWith("/")){
|
|
+ LogDebug() << "Old rpath in" << binaryPath << "starts with /, hence adding it to LD_LIBRARY_PATH";
|
|
+ // FIXME: Split along ":" characters, check each one, only append to LD_LIBRARY_PATH if not already there
|
|
+ QProcessEnvironment env = QProcessEnvironment::systemEnvironment();
|
|
+ QString oldPath = env.value("LD_LIBRARY_PATH");
|
|
+ if (not oldPath.contains(oldRpath)){
|
|
+ QString newPath = oldRpath + ":" + oldPath; // FIXME: If we use a ldd replacement, we still need to observe this path
|
|
+ // FIXME: Directory layout might be different for system Qt; cannot assume lib/ to always be inside the Qt directory
|
|
+ LogDebug() << "Added to LD_LIBRARY_PATH:" << newPath;
|
|
+ setenv("LD_LIBRARY_PATH",newPath.toUtf8().constData(),1);
|
|
+ }
|
|
}
|
|
}
|
|
|
|
- QStringList rpath = oldRpath.split(":", QString::SkipEmptyParts);
|
|
rpath.prepend(id);
|
|
rpath.removeDuplicates();
|
|
foreach(QString path, QStringList(rpath)) {
|