circom-compat-ffi/flake.nix

24 lines
607 B
Nix

{
description = "A flake for building circom-compat (ark-circom) ffi";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.05";
};
outputs = { self, nixpkgs }:
let
stableSystems = [
"x86_64-linux" "aarch64-linux"
"x86_64-darwin" "aarch64-darwin"
];
forAllSystems = nixpkgs.lib.genAttrs stableSystems;
pkgsFor = forAllSystems (system: import nixpkgs { inherit system; });
in
{
packages = forAllSystems (system: let
pkgs = pkgsFor.${system};
in {
default = pkgs.callPackage ./default.nix {};
});
};
}